Intermittent Issues with Cryptocurrency Conversions
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted Nov 11, 2022 - 10:51 GMT+08:00
Identified
The issue has been identified and a fix is being implemented.

In the meantime, you may also log in to Coins Pro using your Coins.ph credentials and trade to buy/sell the crypto. Thank you!
Posted Nov 11, 2022 - 10:00 GMT+08:00
Update
Our team is continuously investigating the issue.

Please be assured that your funds are safe. We're also in close coordination with our technical team to resolve this. Kindly subscribe to our Status Page Incident to receive live updates.

Thank you for your understanding.
Posted Nov 10, 2022 - 12:16 GMT+08:00
Investigating
We are currently investigating this issue.
Posted Nov 09, 2022 - 08:43 GMT+08:00
This incident affected: Digital Currency Conversion (Bitcoin, Bitcoin Cash, Ethereum, AAVE, AXS, SLP, CHZ, YGG, GALA, APE, BAT, ENJ, KNC v2, LINK, LOOKS, MATIC, MKR, SAND, SHIB, MANA, UNI).