Coins.ph Transactions
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 11, 2018 - 18:40 GMT+08:00
Investigating
We are currently experiencing some delays in processing wallet transfers, cash ins, cash outs, bill payments, and load transactions. We sincerely apologize for the inconvenience. Our technical team is already working on resolving this issue at the soonest possible time.
Posted 2 months ago. Sep 11, 2018 - 18:37 GMT+08:00