[InstaPay] Cash Out and Cash In
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted Sep 04, 2020 - 18:57 GMT+08:00
Investigating
We are currently investigating this issue.
Posted Sep 04, 2020 - 14:42 GMT+08:00
This incident affected: Cash In (Instapay Cash In) and Cash Out (Instapay Cash Out, GCash via InstaPay, Paymaya via InstaPay).