Outgoing Ethereum Transactions
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 14, 2019 - 21:06 GMT+08:00
Investigating
We are currently investigating this issue.
Posted 2 months ago. Apr 14, 2019 - 18:26 GMT+08:00
This incident affected: External Ethereum Transfers (Outgoing to External Wallets).