ETH Currency Downtime
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted May 31, 2020 - 19:45 GMT+08:00
Investigating
Kindly note that we're currently experiencing issues with converting ETH and sending ETH funds to external wallets. Our team is already checking on this to bring back full functionality.
Posted May 31, 2020 - 17:09 GMT+08:00
This incident affected: Digital Currency Conversion (Ethereum).