Digital Currency Conversion
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted May 26, 2020 - 17:29 GMT+08:00
Identified
Please note that some customers may experience difficulties in converting funds to other digital currencies. Our team is already aware of this issue and we're working to have this fixed as soon as possible. We're sorry for the inconvenience this may have caused you.
Posted May 25, 2020 - 15:39 GMT+08:00
This incident affected: Digital Currency Conversion (Bitcoin, Bitcoin Cash, Ethereum, XRP).