Coins.ph Transaction Delays
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 07, 2019 - 09:49 GMT+08:00
Identified
We are currently experiencing delays in processing wallet transfers, cash outs, bill payments, and load transactions. We sincerely apologize for the inconvenience. Our technical team is already working on resolving this issue at the soonest possible time.
Posted 3 months ago. Jun 06, 2019 - 22:14 GMT+08:00
This incident affected: Mobile Apps.