[Game Credits] Blizzard
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 11, 2018 - 13:53 GMT+08:00
Investigating
Please be advised that Blizzard Game Credits option is temporarily unavailable. We apologize for any inconvenience this may have caused. We are coordinating with the provider in order to restore functionality at the soonest possible time.
Posted about 1 year ago. Jul 05, 2018 - 14:39 GMT+08:00