Issue processing Bitcoin Cash Transactions
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted May 20, 2021 - 11:32 GMT+08:00
Update
This incident has been resolved.
Posted May 20, 2021 - 11:32 GMT+08:00
Update
We are continuing to investigate this issue.
Posted May 17, 2021 - 08:15 GMT+08:00
Update
We are continuing to investigate this issue.
Posted May 15, 2021 - 12:03 GMT+08:00
Update
We are continuing to investigate this issue.
Posted May 12, 2021 - 14:37 GMT+08:00
Update
We are continuing to investigate this issue.
Posted May 10, 2021 - 16:33 GMT+08:00
Update
We are continuing to investigate this issue.
Posted May 10, 2021 - 14:36 GMT+08:00
Investigating
We are currently investigating this issue.
Posted May 08, 2021 - 15:30 GMT+08:00
This incident affected: External Bitcoin Cash Transfers (Outgoing to External Wallets).