USDT Conversions, Deposits, and Withdrawals

Incident Report for Coins.ph

Resolved

This incident has been resolved.
Posted Mar 12, 2023 - 15:08 GMT+08:00

Investigating

USDT Conversions, Deposits, and Withdrawals are currently unavailable in Coins.ph Our technical team is already looking into the issue.

We ask for your continued patience and understanding on this matter.
Posted Mar 12, 2023 - 13:34 GMT+08:00