Bayad Center Maintenance
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 14, 2018 - 22:53 GMT+08:00
Investigating
Please be advised that Bayad Center is undergoing system maintenance. During this time, Bayad Center bills payment facility will be unavailable.
Posted 7 months ago. Mar 14, 2018 - 18:54 GMT+08:00