Smart/Talk n Text Buy Load
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 10 months ago. Jul 02, 2018 - 21:06 GMT+08:00
Investigating
Please be advised that Smart/Talk n Text load option is temporarily unavailable. We apologize for any inconvenience this may have caused and are working on having it back up as soon as possible.
Posted 10 months ago. Jul 02, 2018 - 21:04 GMT+08:00
This incident affected: Buy Load (Smart / Talk 'N Text).