[Security Bank] Online Banking Cash ins
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 14, 2018 - 18:53 GMT+08:00
Investigating
Please be advised that we are currently experiencing delays with processing Security Bank cash ins. For urgent cash ins, we highly recommend using our instant cash in options. We are coordinating with the bank to resolve this at the soonest possible time. We sincerely apologize for the inconvenience.
Posted 3 months ago. Mar 14, 2018 - 12:12 GMT+08:00