Coins.ph transaction delays
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 23 days ago. Aug 30, 2019 - 19:05 GMT+08:00
Investigating
Please be advised that we are currently experiencing delays with processing transactions. We apologize for any inconvenience this has caused and we are working on having it back up as soon as possible.
Posted 23 days ago. Aug 30, 2019 - 18:47 GMT+08:00
This incident affected: Mobile Apps.