InstaPay System Maintenance

Incident Report for Coins.ph

Resolved

This incident has been resolved.
Posted Nov 13, 2023 - 23:12 GMT+08:00

Investigating

We are currently investigating this issue.
Posted Nov 13, 2023 - 22:24 GMT+08:00
This incident affected: Cash Out (InstaPay Cash Out, BDO via InstaPay, BPI via InstaPay, GCash via InstaPay, Union Bank of the Philippines via Instapay).