Issues with Incoming XRP Transactions
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted Mar 17, 2023 - 10:09 GMT+08:00
Investigating
You may encounter some delays in processing Incoming XRP transfers. Our technical team is currently investigating.
Posted Mar 15, 2023 - 13:44 GMT+08:00
This incident affected: Ripple Network Transfers (XRP) (Deposits).