Game Credits
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 26, 2018 - 17:28 GMT+08:00
Investigating
Please be advised that all game credit options are temporarily unavailable. Our service provider is currently experiencing delays with sending the pins. We apologize for any inconvenience this may have caused and are working on having it back up as soon as possible.
Posted 4 months ago. Feb 26, 2018 - 11:22 GMT+08:00