Coins.ph App and Web Downtime
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted Oct 15, 2019 - 22:55 GMT+08:00
Investigating
Hi there,

Our website is currently down but we are already working on this. Our technical team is making sure that the issue is resolved at the soonest possible time.

We sincerely apologize for the inconvenience this may have caused and thank you so much for your patience!
Posted Oct 15, 2019 - 20:48 GMT+08:00
This incident affected: Coins.ph Website and Mobile Apps.