Globe/TM Load
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 03, 2018 - 22:15 GMT+08:00
Identified
Please be advised that Globe/TM option is temporarily unavailable. We apologize for any inconvenience this may have caused. We are coordinating with the provider in order to restore functionality at the soonest possible time.
Posted 5 months ago. Jul 03, 2018 - 20:12 GMT+08:00
This incident affected: Buy Load (Globe / TM).