Coins.ph Buy Load Service
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 01, 2018 - 16:50 GMT+08:00
Update
We are continuing to investigate this issue.
Posted about 1 year ago. Aug 01, 2018 - 11:17 GMT+08:00
Investigating
Please be advised that our Buy Load service is temporarily unavailable. We apologize for any inconvenience this may have caused and are working on having it back up as soon as possible.
Posted about 1 year ago. Aug 01, 2018 - 11:15 GMT+08:00
This incident affected: Buy Load (Smart / Talk 'N Text, Globe / TM, Sun Cellular).