Issues processing outgoing Bitcoin Cash transactions
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted Dec 17, 2021 - 08:12 GMT+08:00
Investigating
We are currently investigating this issue.
Posted Dec 16, 2021 - 12:10 GMT+08:00
This incident affected: External Bitcoin Cash Transfers (Outgoing to External Wallets).