Issues Processing BTC Outgoing Transactions
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted Mar 30, 2023 - 09:07 GMT+08:00
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 29, 2023 - 17:00 GMT+08:00
Investigating
Please be advised that our BTC withdrawal services are currently disabled. Rest assured that we are closely working with our technical team to resolve the issue as soon as possible.
Posted Mar 28, 2023 - 17:30 GMT+08:00
This incident affected: Bitcoin Network Transfers (Withdrawals).