Issues with SLP Conversions
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted May 15, 2022 - 16:02 GMT+08:00
Update
We are continuing to investigate this issue.
Posted May 15, 2022 - 16:01 GMT+08:00
Investigating
We are currently investigating this issue.
Posted May 12, 2022 - 15:56 GMT+08:00
This incident affected: Digital Currency Conversion (SLP).