Meralco Kuryente Load
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 23, 2018 - 07:43 GMT+08:00
Identified
Please be advised that Meralco KLOAD Bill Payment option is temporarily unavailable due to our service provider's system maintenance. We apologize for any inconvenience this may have caused and are working on having it back up as soon as possible.
Posted 4 months ago. Feb 22, 2018 - 23:32 GMT+08:00