SMS Verification Codes are not being received

Incident Report for Coins.ph

Resolved

This incident has been resolved.
Posted Jun 09, 2022 - 21:40 GMT+08:00

Investigating

We are currently investigating this issue.
Posted Jun 09, 2022 - 11:56 GMT+08:00