Palawan Express Outlet Disabled due to Emergency Maintenance
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted Jul 24, 2024 - 19:54 GMT+08:00
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2024 - 11:05 GMT+08:00
This incident affected: Cash In (Palawan Express Cash In via DragonPay) and Cash Out (Palawan Express Cash Out via DragonPay).