[Coins.ph] Scheduled System Maintenance
Incident Report for Coins.ph
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 18, 2018 - 11:00 GMT+08:00
Identified
Advisory: We will be undergoing system maintenance on November 18, 2018 (Sunday) starting 2:00 AM to 4:00 AM (PH time). During this time, you will not be able to access to your Coins.ph account.

Incoming blockchain-based transactions from external accounts to your Coins.ph account will still push through.
Posted about 1 month ago. Nov 15, 2018 - 11:01 GMT+08:00